PACS

Dear User, in order to access the PACS platform you must have Internet Explorer version 10 or older versions (32 bits), and activate the Active X controls.